Log in

No account? Create an account
'Twas brillig, and the slithy toves did gyre and gimble in the wabe [entries|archive|friends|userinfo]

[ website | Beware the Jabberwock... ]
[ deviantArt | the-boggyb ]
[ FanFiction | Torkell ]
[ Tumblr | torkellr ]

[Random links| BBC news | Vulture Central | Slashdot | Dangerous Prototypes | LWN | Raspberry Pi]
[Fellow blogs| a Half Empty Glass | the Broken Cube | The Music Jungle | Please remove your feet | A letter from home]
[Other haunts| Un4seen Developments | Jazz 2 Online | EmuTalk.net | Feng's shui]

"I'm localhost!" "No, I'm localhost!" [Friday 9th November 2012 at 11:13 pm]

[Tags|, , , ]
[Playing |Zelda themes (Nightbeat) ~ Nightbeat [zelda themes.s3m]]

The other day, support managed to find a network with what appears to be several devices all claiming that they're called "localhost".

They were trying to track down some routing issue or other, and the output from the route command was looking something like:

Destination     Gateway         Genmask         Iface    localhost   eth1    localhost   eth2
default         eth0

Naturally, you assume that you've screwed up your network setup, formed of a maze of twisty little ifcfg-eth0 files. Except on the actual server some of the network interfaces were bonded together, several VLANs were in use, and there was a bridge interface as well somewhere (I forget the actual layout and addresses, so this example has been rather simplified). Anyway, as part of trying to track it down someone tried removing the default interface, and got a routing table something like this:

Destination     Gateway         Genmask         Iface   eth1   eth2

Naturally, you assume that the network scripts are doing weird and unhelpful things. And so you spend ages poking things in an attempt to make sense of the output without managing to make any headway.

Eventually someone tried running "route -n" instead of plain "route", and got this:

Destination     Gateway         Genmask         Iface   eth1   eth2         eth0


It turned out that if you asked the DNS server on that network to do a reverse lookup for, say,, it told you that that the hostname for that address was "localhost". As was the hostname for, or for several other addresses.

Link | Previous Entry | Share | Flag | Next Entry[ One penny | Penny for your thoughts? ]

[User Picture]From: jecook
Sunday 11th November 2012 at 11:22 pm (UTC)
... That reminds me of this clip from the 1960 movie Spartacus.

(Reply) (Thread)